Want to know more
Find specification sheets, feature presentations, and other supporting materials in our download center.
go to download center

Systems
Requirements

Want to use Evidence Lock? Make sure your servers are upgraded

Update all your recording servers to XProtect 2020 R2 to make full use of the Evidence Lock feature in XProtect Corporate.

In order to Evidence Lock video material, users must ensure that associated Recording Servers are updated to at least the 2020 R2 version.

If users choose to do a partial upgrade, they will not be able to Evidence Lock material on recording servers that haven’t been updated.  

Fan of the System Monitor?
Make sure to read this...

When upgrading your XProtect system to the 2020 R2 version, make sure to update all system components. The components that have not been updated to the 2020 R2 version will not show up properly when using the System Monitor.

New support for
Microsoft SQL Server 2019

After great demand, we can now offer support for Microsoft SQL Server 2019.

Please note that the Microsoft SQL Server 2019 is not compatible with Windows 8.1, Windows Server 2012, or Windows Server 2012 R2

If users want to install XProtect 2020 R2 on non-compatible operating systems, they must install a supporting SQL version before installing XProtect.

For more details see our system requirements page

You may also be interested in: